#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m){"old.+}}"
Local $sString = "INFO: AppId=myApp - CompType=logger - CompId=myCompID : Level=INFO - Message={"sourceId":"Data","sourceType":"info","timestamps":{"original":"1543849385073","uiPublish":"1543849385073"},"correlationId":"1543849385073_2272_38","object":{"old":{"mystate":"complete","state":"item"},"new":{"mystate":"complete","state":"myitem"}},"timestamp":"1543849385073"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")