$re = '/{"old.+}}/m';
$str = 'INFO: AppId=myApp - CompType=logger - CompId=myCompID : Level=INFO - Message={"sourceId":"Data","sourceType":"info","timestamps":{"original":"1543849385073","uiPublish":"1543849385073"},"correlationId":"1543849385073_2272_38","object":{"old":{"mystate":"complete","state":"item"},"new":{"mystate":"complete","state":"myitem"}},"timestamp":"1543849385073"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);