const regex = /{"old.+}}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{"old.+}}', 'gm')
const str = `INFO: AppId=myApp - CompType=logger - CompId=myCompID : Level=INFO - Message={"sourceId":"Data","sourceType":"info","timestamps":{"original":"1543849385073","uiPublish":"1543849385073"},"correlationId":"1543849385073_2272_38","object":{"old":{"mystate":"complete","state":"item"},"new":{"mystate":"complete","state":"myitem"}},"timestamp":"1543849385073"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}