using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{""old.+}}";
string input = @"INFO: AppId=myApp - CompType=logger - CompId=myCompID : Level=INFO - Message={""sourceId"":""Data"",""sourceType"":""info"",""timestamps"":{""original"":""1543849385073"",""uiPublish"":""1543849385073""},""correlationId"":""1543849385073_2272_38"",""object"":{""old"":{""mystate"":""complete"",""state"":""item""},""new"":{""mystate"":""complete"",""state"":""myitem""}},""timestamp"":""1543849385073""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}