# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[a-z0-9]{4}\b/****/gm;t' <<< "0314336580
Ionescu Vasile
"