$re = '/[a-z0-9]{4}\b/m';
$str = '0314336580
Ionescu Vasile
';
$subst = "****";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;