re = /[a-z0-9]{4}\b/m
str = '0314336580
Ionescu Vasile
'
subst = '****'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result