#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[a-z0-9]{4}\b"
Local $sString = "0314336580" & @CRLF & _
"Ionescu Vasile" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "****"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)