package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z0-9]{4}\b`)
var str = `0314336580
Ionescu Vasile
`
var substitution = "****"
fmt.Println(re.ReplaceAllString(str, substitution))
}