import Foundation
let pattern = #"[a-z0-9]{4}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0314336580
Ionescu Vasile
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"****"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)