use strict;
my $str = '0314336580
Ionescu Vasile
';
my $regex = qr/[a-z0-9]{4}\b/mp;
my $subst = '****';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";