// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[a-z0-9]{4}\b").unwrap();
let string = "0314336580
Ionescu Vasile
";
let substitution = "****";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}