const regex = /[^a-zA-Za-åa-ö-w-я 0-9/@%!"#?¨'_.,]/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Za-åa-ö-w-я 0-9\/@%!"#?¨\'_.,]', 'gi')
const str = `allows email, text and number in latin and cyrillic alaphbet.
but prevents special charcters.
Hello, :()*&^<>
example@mail.com`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);