re = /[^a-zA-Za-åa-ö-w-я 0-9\/@%!"#?¨'_.,]/i
str = 'allows email, text and number in latin and cyrillic alaphbet.
but prevents special charcters.
Hello, :()*&^<>
example@mail.com'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result