use strict;
my $str = 'allows email, text and number in latin and cyrillic alaphbet.
but prevents special charcters.
Hello, :()*&^<>
example@mail.com';
my $regex = qr/[^a-zA-Za-åa-ö-w-я 0-9/@%!"#?¨'_.,]/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";