# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\.?@([a-z0-9_]{1,25})[^a-z0-9_]?.*$/\1/gm;t' <<< "@address token token token
@address token token /ntoken
@address"