re = /^\.?@([a-z0-9_]{1,25})[^a-z0-9_]?.*$/m
str = '@address token token token
@address token token /ntoken
@address'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result