using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\.?@([a-z0-9_]{1,25})[^a-z0-9_]?.*$";
string substitution = @"\1";
string input = @"@address token token token
@address token token /ntoken
@address";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}