use strict;
my $str = '@address token token token
@address token token /ntoken
@address';
my $regex = qr/^\.?@([a-z0-9_]{1,25})[^a-z0-9_]?.*$/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";