// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\.?@([a-z0-9_]{1,25})[^a-z0-9_]?.*$").unwrap();
let string = "@address token token token
@address token token /ntoken
@address";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}