import re
regex = re.compile(r"^\.?@([a-z0-9_]{1,25})[^a-z0-9_]?.*$", flags=re.MULTILINE)
test_str = ("@address token token token\n"
"@address token token /ntoken\n"
"@address")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)