$re = '/^\.?@([a-z0-9_]{1,25})[^a-z0-9_]?.*$/m';
$str = '@address token token token
@address token token /ntoken
@address';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;