package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\.?@([a-z0-9_]{1,25})[^a-z0-9_]?.*$`)
var str = `@address token token token
@address token token /ntoken
@address`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}