# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a[^>]*>.*?<\/a\s*>(*SKIP)(*FAIL)|\borlistat\b/<a href="ddd">orlistat<\/a>/s;t' <<< "
<li><a href=\"/Dimagrire/Farmaci/orlistat.html\"><strong>Orlistat</strong></a>, inibitore delle lipasi gastroenteriche, in grado di ridurre orlistat sensibilmente l'assorbimento intestinale dei grassi alimentari, tagliando così il potere calorico della dieta. <br />
"