use strict;
my $str = '
<li><a href="/Dimagrire/Farmaci/orlistat.html"><strong>Orlistat</strong></a>, inibitore delle lipasi gastroenteriche, in grado di ridurre orlistat sensibilmente l\'assorbimento intestinale dei grassi alimentari, tagliando così il potere calorico della dieta. <br />
';
my $regex = qr~<a[^>]*>.*?</a\s*>(*SKIP)(*FAIL)|\borlistat\b~sp;
my $subst = '<a href="ddd">orlistat</a>';
my $result = $str =~ s~$regex~$subst~r;
print "The result of the substitution is' $result\n";