// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<a[^>]*>.*?</a\s*>(*SKIP)(*FAIL)|\borlistat\b").unwrap();
let string = "
<li><a href=\"/Dimagrire/Farmaci/orlistat.html\"><strong>Orlistat</strong></a>, inibitore delle lipasi gastroenteriche, in grado di ridurre orlistat sensibilmente l'assorbimento intestinale dei grassi alimentari, tagliando così il potere calorico della dieta. <br />
";
let substitution = "<a href=\"ddd\">orlistat</a>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}