const regex = new RegExp('<a[^>]*>.*?</a\\s*>(*SKIP)(*FAIL)|\\borlistat\\b', 's')
const str = `
<li><a href="/Dimagrire/Farmaci/orlistat.html"><strong>Orlistat</strong></a>, inibitore delle lipasi gastroenteriche, in grado di ridurre orlistat sensibilmente l'assorbimento intestinale dei grassi alimentari, tagliando così il potere calorico della dieta. <br />
`;
const subst = `<a href="ddd">orlistat</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);