using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[^>]*>.*?</a\s*>(*SKIP)(*FAIL)|\borlistat\b";
string substitution = @"<a href=""ddd"">orlistat</a>";
string input = @"
<li><a href=""/Dimagrire/Farmaci/orlistat.html""><strong>Orlistat</strong></a>, inibitore delle lipasi gastroenteriche, in grado di ridurre orlistat sensibilmente l'assorbimento intestinale dei grassi alimentari, tagliando così il potere calorico della dieta. <br />
";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}