$re = '~<a[^>]*>.*?</a\s*>(*SKIP)(*FAIL)|\borlistat\b~s';
$str = '
<li><a href="/Dimagrire/Farmaci/orlistat.html"><strong>Orlistat</strong></a>, inibitore delle lipasi gastroenteriche, in grado di ridurre orlistat sensibilmente l\'assorbimento intestinale dei grassi alimentari, tagliando così il potere calorico della dieta. <br />
';
$subst = "<a href=\"ddd\">orlistat</a>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;