import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a[^>]*>.*?</a\\s*>(*SKIP)(*FAIL)|\\borlistat\\b";
final String string = "\n"
+ " <li><a href=\"/Dimagrire/Farmaci/orlistat.html\"><strong>Orlistat</strong></a>, inibitore delle lipasi gastroenteriche, in grado di ridurre orlistat sensibilmente l'assorbimento intestinale dei grassi alimentari, tagliando così il potere calorico della dieta. <br />\n";
final String subst = "<a href=\"ddd\">orlistat</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}