package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)JLX\\(?:(?:\w(\w{2}\d{5}))|(\w\d{6}))`)
var str = `JLX\BVA12345
JLX\bva12345
JLX\e123456
JLX\c123456
JLX\E123456
JLX\C123456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}