use strict;
my $str = 'JLX\\BVA12345
JLX\\bva12345
JLX\\e123456
JLX\\c123456
JLX\\E123456
JLX\\C123456';
my $regex = qr/JLX\\(?:(?:\w(\w{2}\d{5}))|(\w\d{6}))/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}