import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "JLX\\\\(?:(?:\\w(\\w{2}\\d{5}))|(\\w\\d{6}))";
final String string = "JLX\\BVA12345\n"
+ "JLX\\bva12345\n"
+ "JLX\\e123456\n"
+ "JLX\\c123456\n"
+ "JLX\\E123456\n"
+ "JLX\\C123456";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}