re = /JLX\\(?:(?:\w(\w{2}\d{5}))|(\w\d{6}))/i
str = 'JLX\\BVA12345
JLX\\bva12345
JLX\\e123456
JLX\\c123456
JLX\\E123456
JLX\\C123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end