const regex = /JLX\\(?:(?:\w(\w{2}\d{5}))|(\w\d{6}))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('JLX\\\\(?:(?:\\w(\\w{2}\\d{5}))|(\\w\\d{6}))', 'gi')
const str = `JLX\\BVA12345
JLX\\bva12345
JLX\\e123456
JLX\\c123456
JLX\\E123456
JLX\\C123456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}