$re = '/JLX\\\\(?:(?:\w(\w{2}\d{5}))|(\w\d{6}))/i';
$str = 'JLX\\BVA12345
JLX\\bva12345
JLX\\e123456
JLX\\c123456
JLX\\E123456
JLX\\C123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);