import re
regex = re.compile(r"/[^/]*$", flags=re.MULTILINE)
test_str = ("prežrať/RNE/IGE\n"
"prežrieť/Z\n"
"prežrúc/zZ/32\n"
"prežuť/cgrj")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)