#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(>)old[ ]string(<)|(")old[ ]string(")|(')old[ ]string(')|(\()old[ ]string(\)))"
Local $sString = "(old string) 'old string' old string >old string<" & @CRLF & _
""old string" >old string< old string 'old string'" & @CRLF & _
""
Local $sSubst = "$1$3$5$7new string$2$4$6$8"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)