// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:(>)old[ ]string(<)|(")old[ ]string(")|(')old[ ]string(')|(\()old[ ]string(\)))"#).unwrap();
let string = "(old string) 'old string' old string >old string<
\"old string\" >old string< old string 'old string'
";
let substitution = "$1$3$5$7new string$2$4$6$8";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}