package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(>)old[ ]string(<)|(")old[ ]string(")|(')old[ ]string(')|(\()old[ ]string(\)))`)
var str = `(old string) 'old string' old string >old string<
"old string" >old string< old string 'old string'
`
var substitution = "$1$3$5$7new string$2$4$6$8"
fmt.Println(re.ReplaceAllString(str, substitution))
}