re = /(?:(>)old[ ]string(<)|(")old[ ]string(")|(')old[ ]string(')|(\()old[ ]string(\)))/m
str = '(old string) \'old string\' old string >old string<
"old string" >old string< old string \'old string\'
'
subst = '$1$3$5$7new string$2$4$6$8'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result