using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(>)old[ ]string(<)|("")old[ ]string("")|(')old[ ]string(')|(\()old[ ]string(\)))";
string substitution = @"$1$3$5$7new string$2$4$6$8";
string input = @"(old string) 'old string' old string >old string<
""old string"" >old string< old string 'old string'
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}