use strict;
my $str = '(old string) \'old string\' old string >old string<
"old string" >old string< old string \'old string\'
';
my $regex = qr/(?:(>)old[ ]string(<)|(")old[ ]string(")|(')old[ ]string(')|(\()old[ ]string(\)))/mp;
my $subst = '$1$3$5$7new string$2$4$6$8';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";