import Foundation
let pattern = #"(?:(>)old[ ]string(<)|(")old[ ]string(")|(')old[ ]string(')|(\()old[ ]string(\)))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(old string) 'old string' old string >old string<
"old string" >old string< old string 'old string'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3$5$7new string$2$4$6$8"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)