const regex = /(?:(>)old[ ]string(<)|(")old[ ]string(")|(')old[ ]string(')|(\()old[ ]string(\)))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(>)old[ ]string(<)|(")old[ ]string(")|(\')old[ ]string(\')|(\\()old[ ]string(\\)))', 'gm')
const str = `(old string) 'old string' old string >old string<
"old string" >old string< old string 'old string'
`;
const subst = `$1$3$5$7new string$2$4$6$8`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);