using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http|ftp|https)://([^/\r\n]+)(/[^\r\n]*)?";
string input = @"http://www.radsoftware.com.au/web/
http://www.radsoftware.com.au/web/Default.aspx
https://www.radsoftware.com.au
http://www.radsoftware.com.au/web/CodeZone/Default.aspx?from=RegexDesigner";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}