import re
regex = re.compile(r"(http|ftp|https)://([^/\r\n]+)(/[^\r\n]*)?", flags=re.DOTALL)
test_str = ("http://www.radsoftware.com.au/web/\n"
"http://www.radsoftware.com.au/web/Default.aspx\n"
"https://www.radsoftware.com.au\n"
"http://www.radsoftware.com.au/web/CodeZone/Default.aspx?from=RegexDesigner")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")