package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(http|ftp|https)://([^/\r\n]+)(/[^\r\n]*)?`)
var str = `http://www.radsoftware.com.au/web/
http://www.radsoftware.com.au/web/Default.aspx
https://www.radsoftware.com.au
http://www.radsoftware.com.au/web/CodeZone/Default.aspx?from=RegexDesigner`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}