re = /(http|ftp|https):\/\/([^\/\r\n]+)(\/[^\r\n]*)?/
str = 'http://www.radsoftware.com.au/web/
http://www.radsoftware.com.au/web/Default.aspx
https://www.radsoftware.com.au
http://www.radsoftware.com.au/web/CodeZone/Default.aspx?from=RegexDesigner'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end