$re = '/(http|ftp|https)://([^/\r\n]+)(/[^\r\n]*)?/s';
$str = 'http://www.radsoftware.com.au/web/
http://www.radsoftware.com.au/web/Default.aspx
https://www.radsoftware.com.au
http://www.radsoftware.com.au/web/CodeZone/Default.aspx?from=RegexDesigner';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);